Всякое про программирование

Обсуждение софта. Установка, настройка, новинки. В общем все, что связано с софтом.
Аватара пользователя
arxont
Сообщения: 3315
Зарегистрирован: Пт авг 31, 2012 11:29 pm

Re: Всякое про программирование

Сообщение arxont » Пт июн 14, 2019 3:31 pm

Киберпанк не умер. Он просто наступил.

Аватара пользователя
arxont
Сообщения: 3315
Зарегистрирован: Пт авг 31, 2012 11:29 pm

Re: Всякое про программирование

Сообщение arxont » Чт июн 20, 2019 8:25 am

Киберпанк не умер. Он просто наступил.

Аватара пользователя
arxont
Сообщения: 3315
Зарегистрирован: Пт авг 31, 2012 11:29 pm

Re: Всякое про программирование

Сообщение arxont » Пн июл 29, 2019 4:41 pm

https://habr.com/ru/post/461673/ 8 советов начинающим программистам или ретроспектива моей карьеры
Киберпанк не умер. Он просто наступил.

Аватара пользователя
arxont
Сообщения: 3315
Зарегистрирован: Пт авг 31, 2012 11:29 pm

Re: Всякое про программирование

Сообщение arxont » Вс авг 18, 2019 7:14 am

ПОЛУЧИЛ РАЗРАБ ТЗ,
А ЧТО ДЕЛАТЬ ОН ХЗ,
ТЕКСТ КОНЕЧНО РАЗБЕРЁТ,
НО ДЕДЛАЙН УЖЕ ИДЁТ!
Киберпанк не умер. Он просто наступил.

Аватара пользователя
arxont
Сообщения: 3315
Зарегистрирован: Пт авг 31, 2012 11:29 pm

Re: Всякое про программирование

Сообщение arxont » Вт авг 20, 2019 9:57 pm

Если вдруг кому-нибудь потребуется поставить быстренько Gitlab в виртуалку Ubuntu

Код: Выделить всё

Установка GitLab на виртуальную машину

Ставим Ubuntu Server 18 LTS ( https://ubuntu.com/download/server ) в виртуалке - везде "Далее"

После установки перезагружаемся и обновляемся
	sudo apt update
	sudo apt upgrade
	reboot

Снова заходим в систему и в меню VirtualBox вставляем диск с дополнениями гостевой ОС
	sudo mkdir /media/cdrom
	sudo mount /dev/cdrom /media/cdrom
	cd /media/cdrom
	sudo apt-get install -y dkms build-essential linux-headers-generic linux-headers-$(uname -r)
	sudo su
	./VBoxLinuxAdditions.run
	reboot

Проверяем что дополнения встали -
	lsmod | grep -io vboxgues

Начинаем устанавливать GitLab (Инструкция взята с https://about.gitlab.com/install/#ubuntu )
	sudo apt-get install -y curl openssh-server ca-certificates
	curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ee/script.deb.sh | sudo bash
	sudo EXTERNAL_URL="https://gitlab.example.com" apt-get install gitlab-ee

	sudo nano /etc/gitlab/gitlab.rb
Указываем 
	letsencrypt['enable'] = true
	external_url "https://git.example.com"
	letsencrypt['contact_emails'] = ['admin@example.com']

	sudo gitlab-ctl reconfigure
Также - так как у меня микротик и надо настроить доступ и снаружи, и изнутри, то надо прописать на него Hairpin NAT

Код: Выделить всё

/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1
add action=dst-nat chain=dstnat dst-address=1.1.1.1 dst-port=22 protocol=tcp to-addresses=192.168.100.111
add action=dst-nat chain=dstnat dst-address=1.1.1.1 dst-port=80 protocol=tcp to-addresses=192.168.100.111
add action=dst-nat chain=dstnat dst-address=1.1.1.1 dst-port=443 protocol=tcp to-addresses=192.168.100.111
add action=masquerade chain=srcnat dst-address=192.168.100.111 dst-port=22 protocol=tcp src-address=192.168.100.0/24
add action=masquerade chain=srcnat dst-address=192.168.100.111 dst-port=80 protocol=tcp src-address=192.168.100.0/24
add action=masquerade chain=srcnat dst-address=192.168.100.111 dst-port=443 protocol=tcp src-address=192.168.100.0/24
Киберпанк не умер. Он просто наступил.

Аватара пользователя
arxont
Сообщения: 3315
Зарегистрирован: Пт авг 31, 2012 11:29 pm

Re: Всякое про программирование

Сообщение arxont » Пт сен 20, 2019 3:42 pm

Junior интересуется «чем разрабатывать».
Middle «что разрабатывать».
Senior «зачем разрабатывать».
Киберпанк не умер. Он просто наступил.

Аватара пользователя
arxont
Сообщения: 3315
Зарегистрирован: Пт авг 31, 2012 11:29 pm

Re: Всякое про программирование

Сообщение arxont » Пн сен 30, 2019 1:53 pm

Я спросила у него будут ли у нас релизы в пятницу. Он сказал что-то среднее между «как я устал» и «какие вы все молодцы», только матом
Киберпанк не умер. Он просто наступил.

Аватара пользователя
arxont
Сообщения: 3315
Зарегистрирован: Пт авг 31, 2012 11:29 pm

Re: Всякое про программирование

Сообщение arxont » Вс окт 20, 2019 1:21 pm

Внезапный прикол - есть одна программа (легаси, но меня попросили посмотреть). У меня всё работает идеально. У одного клиента на сопоставимом железе тормозит. Начали разбираться - программа обычное десктопное приложение - WPF. Без каких-то сложномудрых заморочек.

Классическое "НЕ ДОЛЖНО ТОРМОЗИТЬ" и "У МЕНЯ ВСЁ РАБОТАЕТ". DotPeek + DotTrace - выясняется, что там средствами XAML сделана хитрая анимация. Которая и нагружает всё. Но почему тогда у меня не тормозит? Ставлю чистую систему - опа - начинает тормозить.

Ставлю драйвера и обновления - тормозит. НЕ ПОНЯТНА. Ставлю DirectX - перестаёт! Короче WPF в некоторых случаях и для некоторых вещей использует 3D-ускорение. Но если directX нет, то начинает считаться всё на проце и soft-рендером. Что для особо сложных анимаций создаёт тормоза.

PS: Там кому-то руки надо оторвать по самые ягодицы - считается и рисуется логотип с анимацией для разрешения 8К - ПОТОМ МАСШТАБИРУЕТСЯ под текущий путём уменьшения.
Киберпанк не умер. Он просто наступил.

Аватара пользователя
arxont
Сообщения: 3315
Зарегистрирован: Пт авг 31, 2012 11:29 pm

Re: Всякое про программирование

Сообщение arxont » Чт окт 31, 2019 9:04 am

Киберпанк не умер. Он просто наступил.

Аватара пользователя
arxont
Сообщения: 3315
Зарегистрирован: Пт авг 31, 2012 11:29 pm

Re: Всякое про программирование

Сообщение arxont » Пт ноя 01, 2019 3:50 pm

Киберпанк не умер. Он просто наступил.

Ответить